Support forum of the software localization tool Sisulizer


.NET, Delphi, ... - Sisulizer Localization Tool Support Home

Get in contact with the makers of Sisulizer.
Our forum is open for all questions around Sisulizer from customers and prospects.
Don't hesitate to register and ask. The Sisulizer team will answer ASAP.

Search     Help Home Sisulizer Website Download
Search by username
Not logged in - Login | Register 

 Moderated by: Renate.Reinartz
New Topic Reply Printer Friendly
CHM Project: HTML Attributs are interpreted as text - Bugs and Quirks in Sisulizer - Technical Support (You need to be registered at the forum to write) - .NET, Delphi, ... - Sisulizer Localization Tool Support
AuthorPost
 Posted: Wed Feb 9th, 2011 04:27 pm
PM Private Upload Quote Reply
josefder1
Member
 

Joined: Mon Aug 6th, 2007
Location: Offingen, Germany
Posts: 92
Status: 
Offline
Hello,

this is the chm source line

<p>command bar: &nbsp;<span class=Emphasis>2dintersection</span></p>

and this is what sisulizer shows to translate

command bar: &nbsp;<span class=Emphasis>2dintersection</span>

this is what I get in the target chm file

p>command bar: &lt;span class=Emphasis&gt;2dintersection&lt;/span&gt;</p>

I think this was in Build 311 ok


is it possible to step back to Build 311 or is their another solution for this problem?

Kind Regards
Walter

Back To Top PM Private Upload Quote Reply

 Posted: Wed Feb 9th, 2011 04:41 pm
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3322
Status: 
Offline
Hi,

Despite the fact that we should look into it there is always a possibility to download older builds:

http://www.sisulizer.com/support/versionarchive.shtml

Best

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Wed Feb 9th, 2011 05:03 pm
PM Private Upload Quote Reply
josefder1
Member
 

Joined: Mon Aug 6th, 2007
Location: Offingen, Germany
Posts: 92
Status: 
Offline
Hello Markus,

I have the installation for older builds saved on my computer. I like to ask if it is possible to use the slp file edited with Build 312 again with Build 311.

kind Regards
Walter

Back To Top PM Private Upload Quote Reply

 Posted: Wed Feb 9th, 2011 06:46 pm
PM Private Upload Quote Reply
Janusz Grzybek
Super Moderator


Joined: Fri Dec 1st, 2006
Location: Zabrze, Poland
Posts: 3877
Status: 
Offline
Value of class attribute in Span tag has missed quotation marks, and for this reason Sisulizer can't correctly recognize this paragraph. If you replace <span class=Emphasis> with <span class="Emphasis">, Sisulizer correctly scan this item.

Best regards,
Janusz



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Wed Feb 9th, 2011 08:16 pm
PM Private Upload Quote Reply
Markus.Kreisel
Administrator


Joined: Sat Apr 8th, 2006
Location: Monschau, Germany
Posts: 3322
Status: 
Offline
Hi,

To my knowledge there was no change in the file structure. Make a backup and store it at a safe place in any case.

Anyway it seems that Janusz found some workaround.

Markus



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Thu Feb 10th, 2011 10:46 am
PM Private Upload Quote Reply
josefder1
Member
 

Joined: Mon Aug 6th, 2007
Location: Offingen, Germany
Posts: 92
Status: 
Offline
Hello Janusz,

I think your suggesten Works but in my chm files all  of this tags has no quots

In Build 311 this file works fine since build 312 I have this problem.

maybe the &nbsp; is the problem

in lines like the following the scan works fine also with build 312

<p>: <span class=Emphasis style="font-weight: bold;">2dintersection</span></p>

I send my source file with prvat upload

Kind Regards
Walter

Back To Top PM Private Upload Quote Reply

 Posted: Thu Feb 10th, 2011 11:15 am
PM Private Upload Quote Reply
Janusz Grzybek
Super Moderator


Joined: Fri Dec 1st, 2006
Location: Zabrze, Poland
Posts: 3877
Status: 
Offline
No, &nbsp; is not reason of the issue, because issue still occurs after removing &nbsp; from paragrah (with non quoted value of class attribute). I'll check this problem with build 311.

Best,
Janusz



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Thu Feb 10th, 2011 03:14 pm
PM Private Upload Quote Reply
Janusz Grzybek
Super Moderator


Joined: Fri Dec 1st, 2006
Location: Zabrze, Poland
Posts: 3877
Status: 
Offline
You are right, build 311 can correctly recognize tags, if values of attributes aren't enclosed in quotation marks. I forwarded this to our developers.

Workaround:
  • Don't change (don't remove tags) existing translations for originals with missed sub-tags in Sisulizer project.
  • For empty translation cell use "Copy original to translation" feature (available via sheet toolbar or translation cell's context menu) before translating. It should keep original structure of tags. Don't use standard Copy/Paste feature. Below is screenshot with results.
Best regards,
Janusz

Attachment: screen2.png (Downloaded 24 times)



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Fri Mar 4th, 2011 09:24 pm
PM Private Upload Quote Reply
Ilkka.Salmenius
Moderator


Joined: Wed Aug 8th, 2007
Location: Tokyo, Japan
Posts: 2012
Status: 
Offline
I fixed this. Will be in the next build.

Ilkka



____________________
http://www.sisulizer.com - Three simple steps to localize
Back To Top PM Private Upload Quote Reply

 Posted: Fri Aug 13th, 2021 01:41 pm
PM Private Upload Quote Reply
Mike68
Member
 

Joined: Tue Sep 20th, 2011
Location: Switzerland
Posts: 15
Status: 
Offline
Hi, evenso this topic is really old, i only today started translation of an html file and seen same problem.
my source text shows
<span>
Diese E-Mail enthält vertrauliche Informationen zu
Ihrem Benutzerkonto – leiten Sie diese deshalb bitte nicht weiter.
</span>

In siszulizer, the original is shown like:
Diese E-Mail enthält vertrauliche Informationen zu
Ihrem Benutzerkonto - leiten Sie diese deshalb bitte nicht weiter.

So the – (should show& ndash; ) is represented as -

In the export file (xls) for translation it has – (should show& ndash; ) in it as normal text. Do i expect something wrong? Is this the expected behavior?
Even text cells where only  space is in, like <p><span> (should show& nbsp; )</span></p>, it is exported to be translated...
I am using V4.0 Build 374

Back To Top PM Private Upload Quote Reply

Current time is 07:07 pm  
.NET, Delphi, ... - Sisulizer Localization Tool Support > Technical Support (You need to be registered at the forum to write) > Bugs and Quirks in Sisulizer > CHM Project: HTML Attributs are interpreted as text



WowUltra modified by Sisulizer Copyright © 2007-18 by Jim Hale - Based on WowBB Copyright © 2003-2006 Aycan Gulez

Impress - Privacy statement

Sisulizer software localization tool - Three simple steps to localize